24 lines
717 B
Makefile
24 lines
717 B
Makefile
################################################################################
|
|
#
|
|
# ibm-sw-tpm2
|
|
#
|
|
################################################################################
|
|
|
|
IBM_SW_TPM2_VERSION = 5452af422edeff70fcae8ea99dd28a0922051d7b
|
|
IBM_SW_TPM2_SITE = https://git.code.sf.net/p/ibmswtpm2/tpm2
|
|
IBM_SW_TPM2_SITE_METHOD = git
|
|
IBM_SW_TPM2_LICENSE = BSD-3-Clause
|
|
IBM_SW_TPM2_LICENSE_FILES = LICENSE
|
|
IBM_SW_TPM2_DEPENDENCIES = openssl
|
|
|
|
define IBM_SW_TPM2_BUILD_CMDS
|
|
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS)
|
|
endef
|
|
|
|
define IBM_SW_TPM2_INSTALL_TARGET_CMDS
|
|
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/src $(TARGET_CONFIGURE_OPTS) install \
|
|
DESTDIR=$(TARGET_DIR)
|
|
endef
|
|
|
|
$(eval $(generic-package))
|