16 lines
733 B
Makefile
16 lines
733 B
Makefile
################################################################################
|
|
#
|
|
# python-setuptools-rust
|
|
#
|
|
################################################################################
|
|
|
|
PYTHON_SETUPTOOLS_RUST_VERSION = 1.6.0
|
|
PYTHON_SETUPTOOLS_RUST_SOURCE = setuptools-rust-$(PYTHON_SETUPTOOLS_RUST_VERSION).tar.gz
|
|
PYTHON_SETUPTOOLS_RUST_SITE = https://files.pythonhosted.org/packages/0e/c9/6f9de9f7a8404416d5d22484ccdeb138f469cc1e11bbd62a2bd26d5c1385
|
|
PYTHON_SETUPTOOLS_RUST_SETUP_TYPE = setuptools
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE = MIT
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE_FILES = LICENSE
|
|
HOST_PYTHON_SETUPTOOLS_RUST_DEPENDENCIES = host-rustc host-python-semantic-version host-python-typing-extensions
|
|
|
|
$(eval $(host-python-package))
|