19 lines
739 B
Makefile
19 lines
739 B
Makefile
################################################################################
|
|
#
|
|
# python-setuptools-rust
|
|
#
|
|
################################################################################
|
|
|
|
PYTHON_SETUPTOOLS_RUST_VERSION = 1.8.1
|
|
PYTHON_SETUPTOOLS_RUST_SOURCE = setuptools-rust-$(PYTHON_SETUPTOOLS_RUST_VERSION).tar.gz
|
|
PYTHON_SETUPTOOLS_RUST_SITE = https://files.pythonhosted.org/packages/f2/40/f1e9fedb88462248e94ea4383cda0065111582a4d5a32ca84acf60ab1107
|
|
PYTHON_SETUPTOOLS_RUST_SETUP_TYPE = setuptools
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE = MIT
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE_FILES = LICENSE
|
|
HOST_PYTHON_SETUPTOOLS_RUST_DEPENDENCIES = \
|
|
host-python-semantic-version \
|
|
host-python-setuptools-scm \
|
|
host-rustc
|
|
|
|
$(eval $(host-python-package))
|