19 lines
739 B
Makefile
19 lines
739 B
Makefile
################################################################################
|
|
#
|
|
# python-setuptools-rust
|
|
#
|
|
################################################################################
|
|
|
|
PYTHON_SETUPTOOLS_RUST_VERSION = 1.9.0
|
|
PYTHON_SETUPTOOLS_RUST_SOURCE = setuptools-rust-$(PYTHON_SETUPTOOLS_RUST_VERSION).tar.gz
|
|
PYTHON_SETUPTOOLS_RUST_SITE = https://files.pythonhosted.org/packages/9d/f1/2cb8887cad0726a5e429cc9c58e30767f58d22c34d55b075d2f845d4a2a5
|
|
PYTHON_SETUPTOOLS_RUST_SETUP_TYPE = setuptools
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE = MIT
|
|
PYTHON_SETUPTOOLS_RUST_LICENSE_FILES = LICENSE
|
|
HOST_PYTHON_SETUPTOOLS_RUST_DEPENDENCIES = \
|
|
host-python-semantic-version \
|
|
host-python-setuptools-scm \
|
|
host-rustc
|
|
|
|
$(eval $(host-python-package))
|